Piensa Technologies

  >  Foro de Principiantes en Linux - Mensaje
Indice del Foro 
Búsqueda 
 
Búsqueda Especializada  
 
Ingresar  
Nuevo Mensaje al Foro  
 
 Acerca de Linux
La Gaceta de Linux 
Edición en español 
Gazeta do Linux 
Edición en portugués 
Foro de Principiantes 
> Mensaje
error sin sentido
Ingresado por PEPE el día miércoles abril 09, @04:55 .
Tema: [ Linux en General ]

Hola, no se porque pero tengo un problema y no se como solucionarlo porque al intentar ejecutar algunos archivos ejevutables me da un error de permiso denegado y los permisos de ejecución estan activos para mi usuario, lo mas gracioso esque desde root tengo el mismo problema, ¿por que puede ser? si sirve de algo tb me pasaba con los scripts al poner ./script, sin embargo con sh script me funciona, raro, no?mi interprete es el bash y la distribucion SuSe 8.9 por si facilita algo las cosas, Gracias

[ Ingresar Comentario ]

<  |  >

> Comentarios
Re: error sin sentido
por Ursusmaritimus el día jueves abril 10, @06:38

Quizas se deba a que no has "transformado" un archivo para que se pueda ejecutar, esto se hace asi:

chmod +x nombrearchivo

saludos

[ Ingresar Comentario ]

 

  • Re: error sin sentido
    por: carlos el día lunes septiembre 15, @12:59

    es en alguna particion de windows ?

    [ Ingresar comentario ]
Re: error sin sentido-Solucion
por jjbueno el día viernes junio 18, @06:36

A mi me sucedio con el SUSE 9.0, al investigar mucho encontre que la causa era al instalar, en el punto cuando se configura las particiones en opciones de una particion si se le da que puede ser montada por un usuario. Se puede corregir si ya esta instalado asi: En el archivo /etc/fstab una línea como esta: /dev/hda10/mnt/lfsext2 user1 2 'user' es el parámetro de mount que está causando el problema. Citando la página del manual (man) de mount: user Permite a un usuario ordinario montar el sistema de ficheros. Esta opción implica las opciones noexec, nosuid y nodev (a menos que se sustituyan por otras subsiguientes, como en la línea de opciones user,exec,dev,suid). Por ello, cambia la línea del fichero /etc/fstab a algo como esto: /dev/hda10/mnt/lfsext2 defaults 1 2 Espero que te funcione, a mi me quito un gran dolor de cabeza. Jairo J.B.S.

[ Ingresar Comentario ]

 

Relacionado
  • Más acerca de Linux en General
  • Mismo autor PEPE
  • Contacto con el autor